Welcome!
This repo contains our effort to produce a Full Standard document for BGP, replacing RFC4271.
Here is our to-do list, plus the people working on each item.
There are topics that we’ve agreed to include (Committed), in discussion,
and topics that we’ve agreed should not be included (but could be referenced).
We’ve agreed that we do not want to try to boil the ocean and want the smallest change that gets us to a full standard.
Committed
Errata
These are listed by errata ID. Please use one pull request per errata.
- 150 (tli)
- 1633 (tli)
- 2838 (tli)
- 3264 (tli)
- 3459 (tli)
- 3464 (tli)
- 3809 (tli)
- 4493 (tli)
- 4496 (tli)
- 5000 (tli)
- 5001 (tli)
- 5369 (tli)
- 5421 (tli)
- 5766 (tli)
- 6256 (tli)
- 6498 (tli)
- 8406 (jgs)
In discussion
- RFC 4724 – Graceful restart
- RFC 6286 – BGP identifier
- RFC 6608 – New FSM error codes
- RFC 6793 – 4 Octet AS
- RFC 7606 – Error handling
- RFC 7607 – AS 0 handling
- RFC 7705 - Autonomous System Migration Mechanisms and Their Effects on the BGP AS_PATH Attribute
- RFC 8212 – Default External BGP (EBGP) Route Propagation Behavior without Policies
- RFC 8654 – Change to allow Extended BGP message size (65,535) for all messages except OPEN and KEEPALIVE
- RFC 9072 – Extended option
- RFC 9687 – Send Hold timer
- RFC4724
- RFC6793
- RFC7606
- RFC9072
- RFC9687
- capabilities
- add paths
- multiprotocol? (needed for ipv6)
- deprecate as-set/confed-set.
- reflection
- confederations?
- timer updates for mrai/maoi?
Rejected